ath: Add config option for DFS support
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 3 May 2014 21:14:56 +0000 (21:14 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 3 May 2014 21:14:56 +0000 (21:14 +0000)
This patch adds a config option to enable DFS in ath9k and ath10k
drivers (with ath10k you need the AP-branch firmware). I'm not entirely
sure about the regulatory compliance issues, though. As far as I
understand, enabling the DFS_CERTIFIED config options implies that the
device is certified for DFS. No doubt the original firmware has obtained
such a certification, but not with the open source drivers. I suppose
that as long as this is disabled in default builds (like ATH_USER_REGD)
everything should be fine, but it would be nice to have out-of-the-box
OpenWrt support for DFS. I'm also not sure whether the description of
the configuration option should say something about regulatory compliance.

Signed-off-by: Matti Laakso <malaakso@elisanet.fi>
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40692 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/mac80211/Makefile

index 845bef8..d1759fd 100644 (file)
@@ -39,6 +39,7 @@ PKG_CONFIG_DEPENDS:= \
        CONFIG_PACKAGE_MAC80211_DEBUGFS \
        CONFIG_PACKAGE_MAC80211_MESH \
        CONFIG_PACKAGE_ATH_DEBUG \
+       CONFIG_PACKAGE_ATH_DFS \
        CONFIG_PACKAGE_B43_DEBUG \
        CONFIG_PACKAGE_B43_PIO \
        CONFIG_PACKAGE_B43_N_PHY \
@@ -510,6 +511,16 @@ define KernelPackage/ath/config
                help
                  Say Y, if you want to debug atheros wireless drivers.
                  Right now only ath9k makes use of this.
+
+       config PACKAGE_ATH_DFS
+               bool "Enable DFS support"
+               help
+                 Dynamic frequency selection (DFS) is required for most of the 5 GHz band
+                 channels in Europe, US, and Japan.
+
+                 Select this option if you want to use such channels. Only EU (ETSI) DFS
+                 is supported at the moment.
+
   endif
 endef
 
@@ -1380,6 +1391,7 @@ config-$(call config_package,lib80211) += LIB80211 LIB80211_CRYPT_WEP LIB80211_C
 
 config-$(call config_package,ath) += ATH_CARDS ATH_COMMON
 config-$(CONFIG_PACKAGE_ATH_DEBUG) += ATH_DEBUG ATH10K_DEBUG
+config-$(CONFIG_PACKAGE_ATH_DFS) += ATH9K_DFS_CERTIFIED ATH10K_DFS_CERTIFIED
 
 config-$(call config_package,ath9k) += ATH9K
 config-$(call config_package,ath9k-common) += ATH9K_COMMON