[packages/*] remove special treatment when using glibc - support got dropped
authormirko <mirko@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 28 Apr 2012 22:24:20 +0000 (22:24 +0000)
committermirko <mirko@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 28 Apr 2012 22:24:20 +0000 (22:24 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@31505 3c298f89-4303-0410-b956-a3cf2f4a3e73

devel/dmalloc/Makefile
devel/electric-fence/Makefile
lang/perl/Makefile
libs/gconv-modules/Makefile [deleted file]
utils/pciutils/Makefile

index 1623d58..e746afb 100644 (file)
@@ -30,7 +30,7 @@ endef
 define Package/libdmalloc
   $(call Package/dmalloc/Default)
   TITLE+= (library)
-  DEPENDS:=@USE_GLIBC||@USE_EGLIBC
+  DEPENDS:=@USE_EGLIBC
 endef
 
 define Package/dmalloc-utils
index af049ef..1153350 100644 (file)
@@ -22,7 +22,7 @@ define Package/electric-fence
   CATEGORY:=Development
   TITLE:=electric-fence
   URL:=http://perens.com/FreeSoftware/ElectricFence/
-  DEPENDS:=@USE_GLIBC||@USE_EGLIBC
+  DEPENDS:=@USE_EGLIBC
   MAINTAINER:=Mirko Vogt <mirko@openwrt.org>
 endef
 
index 125cb5a..b059ac4 100644 (file)
@@ -22,7 +22,7 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/perl/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
-ifneq ($(CONFIG_USE_EGLIBC)$(CONFIG_USE_GLIBC),)
+ifneq ($(CONFIG_USE_EGLIBC),)
 EXTRA_LIBS:=bsd
 EXTRA_LIBDIRS:=$(STAGING_DIR)/lib
 endif
@@ -33,7 +33,7 @@ define Package/perl/Default
   CATEGORY:=Languages
   TITLE:=The Perl intepreter
   URL:=http://www.perl.com/
-  DEPENDS:=+USE_EGLIBC:libbsd +USE_GLIBC:libbsd
+  DEPENDS:=+USE_EGLIBC:libbsd
 endef
 
 define Package/microperl
diff --git a/libs/gconv-modules/Makefile b/libs/gconv-modules/Makefile
deleted file mode 100644 (file)
index 6e0f7fc..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-# 
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=gconv-modules
-PKG_VERSION:=$(CONFIG_GLIBC_VERSION)
-PKG_RELEASE:=2
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/gconv-modules
-  SECTION:=libs
-  CATEGORY:=Libraries
-  DEPENDS:=@USE_GLIBC
-  TITLE:=The GNU libc charset conversion modules
-endef
-
-define Package/gconv-modules/description
- This package contains helper modules necessary to convert data between
-various charsets.
-endef
-
-define Build/Compile
-endef
-
-define Package/gconv-modules/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(TOOLCHAIN_DIR)/usr/lib/gconv $(1)/usr/lib
-
-       rm -f $(1)/usr/lib/gconv/EUC-*.so
-       rm -f $(1)/usr/lib/gconv/ISO-2022-*.so
-       rm -f $(1)/usr/lib/gconv/JOHAB.so
-       rm -f $(1)/usr/lib/gconv/UHC.so
-
-#      $(INSTALL_DIR) $(1)/usr/bin
-#      $(INSTALL_BIN) $(TOOLCHAIN_DIR)/usr/bin/iconv $(1)/usr/bin
-endef
-
-$(eval $(call BuildPackage,gconv-modules))
index 31f7a02..32c0f69 100644 (file)
@@ -45,7 +45,7 @@ MAKE_FLAGS += \
        HOST="$(GNU_TARGET_NAME)" \
        ZLIB="yes" \
 
-ifneq ($(CONFIG_USE_EGLIBC)$(CONFIG_USE_GLIBC),)
+ifneq ($(CONFIG_USE_EGLIBC),)
 TARGET_LDFLAGS += -lresolv
 endif