openldap: update to 2.4.39
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 6 Feb 2014 21:11:23 +0000 (21:11 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 6 Feb 2014 21:11:23 +0000 (21:11 +0000)
Without TARGET_CFLAGS += -lpthread it does not find libpthread and the
build fails.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39513 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/openldap/Makefile
libs/openldap/patches/001-automake-compat.patch
libs/openldap/patches/750-no-strip.patch

index a9cb408..5344080 100644 (file)
@@ -8,15 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openldap
-PKG_VERSION:=2.4.23
-PKG_RELEASE:=4
+PKG_VERSION:=2.4.39
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/ \
        ftp://sunsite.cnlab-switch.ch/mirror/OpenLDAP/openldap-release/ \
        ftp://ftp.nl.uu.net/pub/unix/db/openldap/openldap-release/ \
        ftp://ftp.plig.org/pub/OpenLDAP/openldap-release/
-PKG_MD5SUM:=90150b8c0d0192e10b30157e68844ddf
+PKG_MD5SUM:=b0d5ee4b252c841dec6b332d679cf943
 
 PKG_FIXUP:=autoreconf
 
@@ -37,7 +37,7 @@ define Package/libopenldap
   $(call Package/openldap/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libopenssl +libsasl2
+  DEPENDS:=+libopenssl +libsasl2 +libpthread
   TITLE+= (libraries)
 endef
 
@@ -80,7 +80,7 @@ define Package/openldap-server/conffiles
 /etc/openldap/slapd.conf
 endef
 
-TARGET_CFLAGS += $(FPIC)
+TARGET_CFLAGS += $(FPIC) -lpthread
 
 CONFIGURE_ARGS += \
        --enable-shared \
index 4ab2622..71cdebe 100644 (file)
 +SHELL = @SHELL@
 +
  PROGRAMS = slapd-tester slapd-search slapd-read slapd-addel slapd-modrdn \
-               slapd-modify slapd-bind ldif-filter
+               slapd-modify slapd-bind slapd-mtread ldif-filter
  
 --- a/servers/slapd/back-bdb/Makefile.in
 +++ b/servers/slapd/back-bdb/Makefile.in
  SRCS = ldif.c
  OBJS = ldif.lo
  
+--- a/servers/slapd/back-mdb/Makefile.in
++++ b/servers/slapd/back-mdb/Makefile.in
+@@ -13,6 +13,8 @@
+ ## top-level directory of the distribution or, alternatively, at
+ ## <http://www.OpenLDAP.org/license.html>.
++SHELL = @SHELL@
++
+ SRCS = init.c tools.c config.c \
+       add.c bind.c compare.c delete.c modify.c modrdn.c search.c \
+       extended.c operational.c \
 --- a/servers/slapd/back-meta/Makefile.in
 +++ b/servers/slapd/back-meta/Makefile.in
 @@ -13,6 +13,8 @@
index e771dcb..a70aacc 100644 (file)
@@ -11,7 +11,7 @@
        )
 --- a/servers/slapd/Makefile.in
 +++ b/servers/slapd/Makefile.in
-@@ -377,7 +377,7 @@ install-local-srv: install-slapd install
+@@ -380,7 +380,7 @@ install-local-srv: install-slapd install
  install-slapd: FORCE
        -$(MKDIR) $(DESTDIR)$(libexecdir)
        -$(MKDIR) $(DESTDIR)$(localstatedir)/run