[packages] xinetd: update to 2.3.15 (CVE-2012-0862), use CONFIGURE_{ARGS,VARS} &...
authorswalker <swalker@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 27 May 2012 00:09:00 +0000 (00:09 +0000)
committerswalker <swalker@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 27 May 2012 00:09:00 +0000 (00:09 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@31866 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/xinetd/Makefile
net/xinetd/patches/001-ar.patch
net/xinetd/patches/002-destdir.patch
net/xinetd/patches/003-rpc_fix.patch

index 52b1dea..c2bd6e0 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2011 OpenWrt.org
+#
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xinetd
-PKG_VERSION:=2.3.14
-PKG_RELEASE:=3
+PKG_VERSION:=2.3.15
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.xinetd.org/
-PKG_MD5SUM:=567382d7972613090215c6c54f9b82d9
+PKG_SOURCE_URL:=http://www.xinetd.org
+PKG_MD5SUM:=77358478fd58efa6366accae99b8b04c
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -38,22 +40,14 @@ endef
 
 TARGET_CFLAGS += -DNO_RPC
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --without-libwrap \
-               --with-loadavg \
-               , \
-               ac_cv_header_rpc_pmap_clnt_h=no \
-               ac_cv_header_rpc_rpc_h=no \
-               ac_cv_header_rpc_rpcent_h=no \
-       )
-endef
+CONFIGURE_ARGS += \
+       --without-libwrap \
+       --with-loadavg
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               build install
-endef
+CONFIGURE_VARS += \
+       ac_cv_header_rpc_pmap_clnt_h=no \
+       ac_cv_header_rpc_rpc_h=no \
+       ac_cv_header_rpc_rpcent_h=no
 
 define Package/xinetd/install
        $(INSTALL_DIR) $(1)/usr/sbin
index b956648..4d961ba 100644 (file)
@@ -1,6 +1,6 @@
 --- a/libs/src/misc/Makefile.in
 +++ b/libs/src/misc/Makefile.in
-@@ -62,7 +62,7 @@
+@@ -62,7 +62,7 @@ libopt: clean
  
  
  $(LIBNAME): $(OBJECTS)
@@ -11,7 +11,7 @@
  install: $(LIBNAME)
 --- a/libs/src/portable/Makefile.in
 +++ b/libs/src/portable/Makefile.in
-@@ -57,7 +57,7 @@
+@@ -57,7 +57,7 @@ libopt: clean
  
  
  $(LIBNAME): $(OBJECTS)
@@ -22,7 +22,7 @@
  install: $(LIBNAME)
 --- a/libs/src/pset/Makefile.in
 +++ b/libs/src/pset/Makefile.in
-@@ -53,7 +53,7 @@
+@@ -53,7 +53,7 @@ libopt: clean
        mv $(LIBNAME) $(LIBDIR)/optimized
  
  $(LIBNAME): $(OBJECTS)
@@ -33,7 +33,7 @@
  install: $(LIBNAME)
 --- a/libs/src/sio/Makefile.in
 +++ b/libs/src/sio/Makefile.in
-@@ -52,7 +52,7 @@
+@@ -52,7 +52,7 @@ libopt: clean
        $(INSTALL) $(FMODE) $(LIBNAME) $(LIBDIR)/optimized
  
  $(LIBNAME): $(OBJECTS)
@@ -44,7 +44,7 @@
  install: $(LIBNAME)
 --- a/libs/src/str/Makefile.in
 +++ b/libs/src/str/Makefile.in
-@@ -63,7 +63,7 @@
+@@ -63,7 +63,7 @@ libopt: clean
        $(INSTALL) $(FMODE) $(LIBNAME) $(LIBDIR)-O
  
  $(LIBNAME): $(OBJECTS)
@@ -55,7 +55,7 @@
  LINT_IGNORE=possible pointer alignment|RCSid unused
 --- a/libs/src/xlog/Makefile.in
 +++ b/libs/src/xlog/Makefile.in
-@@ -58,7 +58,7 @@
+@@ -58,7 +58,7 @@ libopt: clean
        $(INSTALL) $(FMODE) $(LIBNAME) $(LIBDIR)/optimized
  
  $(LIBNAME): $(OBJECTS)
index ebecaae..89075c8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile.in
 +++ b/Makefile.in
-@@ -75,15 +75,15 @@
+@@ -75,15 +75,15 @@ dlibxlog: dlibsio dlibstr
  
  install: build
        for i in $(DAEMONDIR) $(BINDIR) $(MANDIR)/man5 $(MANDIR)/man8 ; do \
index d790a89..11f47e7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/xinetd/confparse.c
 +++ b/xinetd/confparse.c
-@@ -716,7 +716,7 @@ static status_e check_entry( struct serv
+@@ -745,7 +745,7 @@ static status_e check_entry( struct serv
           }
     }
  
@@ -9,7 +9,7 @@
  #if defined(HAVE_RPC_RPCENT_H) || defined(HAVE_NETDB_H)
     if ( SC_IS_RPC( scp ) && !SC_IS_UNLISTED( scp ) )
     {
-@@ -730,6 +730,7 @@ static status_e check_entry( struct serv
+@@ -759,6 +759,7 @@ static status_e check_entry( struct serv
        SC_RPCDATA( scp )->rd_program_number = rep->r_number ;
     }
     else