[packages] drop palantir as v4l was dropped
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 7 Jun 2012 15:01:07 +0000 (15:01 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 7 Jun 2012 15:01:07 +0000 (15:01 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@32111 3c298f89-4303-0410-b956-a3cf2f4a3e73

multimedia/palantir/Makefile [deleted file]
multimedia/palantir/patches/001-opt_flags.patch [deleted file]

diff --git a/multimedia/palantir/Makefile b/multimedia/palantir/Makefile
deleted file mode 100644 (file)
index d80ac50..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
-#
-# Copyright (C) 2006-2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=palantir
-PKG_VERSION:=2.7
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
-PKG_SOURCE_URL:=http://www.fastpath.it/products/palantir/pub/
-PKG_MD5SUM:=3a5b1fb340857f6d8e357bf39b77583e
-
-PKG_BUILD_DEPENDS:=libjpeg
-
-define Package/palantir
-  SECTION:=multimedia
-  CATEGORY:=Multimedia
-  DEPENDS:=+libjpeg +libpthread
-  TITLE:=A multichannel interactive streaming solution
-  URL:=http://www.fastpath.it/products/palantir/
-endef
-
-define Package/palantir/description
-       Palantir is a Linux-based streaming system designed to transmit live
-       video, audio and data over a TCP/IP network, as well as to control
-       remote devices.
-endef
-
-define Package/palantir/conffiles
-/etc/palantir.conf
-endef
-
-include $(INCLUDE_DIR)/package.mk
-
-export CPPFLAGS=$(TARGET_CPPFLAGS)
-export LDFLAGS=$(TARGET_LDFLAGS)
-
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR)/server/libgsm \
-               $(TARGET_CONFIGURE_OPTS) \
-               CCINC="$(TARGET_CPPFLAGS)" \
-               COPTS="$(TARGET_CFLAGS)" \
-               lib/libgsm.a
-       $(MAKE) -C $(PKG_BUILD_DIR)/server \
-               $(TARGET_CONFIGURE_OPTS) \
-               COPTS="$(TARGET_CFLAGS)" \
-               palantir
-endef
-
-define Package/palantir/install        
-       $(INSTALL_DIR) $(1)/etc
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/server/palantir-mips.conf.sample $(1)/etc/palantir.conf
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/server/palantir $(1)/usr/sbin/
-endef
-
-$(eval $(call BuildPackage,palantir))
diff --git a/multimedia/palantir/patches/001-opt_flags.patch b/multimedia/palantir/patches/001-opt_flags.patch
deleted file mode 100644 (file)
index 1707ecb..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: palantir-2.7/server/libgsm/Makefile
-===================================================================
---- palantir-2.7.orig/server/libgsm/Makefile   2008-04-07 22:35:39.000000000 +0200
-+++ palantir-2.7/server/libgsm/Makefile        2008-04-07 22:35:39.000000000 +0200
-@@ -53,7 +53,7 @@
- endif
- CC            += -ansi -pedantic
--CCFLAGS       = -c -O2 -DNeedFunctionPrototypes=1
-+CCFLAGS       = -c $(COPTS) -DNeedFunctionPrototypes=1
- LD            = $(CC)
-Index: palantir-2.7/server/Makefile
-===================================================================
---- palantir-2.7.orig/server/Makefile  2008-04-07 22:35:39.000000000 +0200
-+++ palantir-2.7/server/Makefile       2008-04-07 22:35:39.000000000 +0200
-@@ -47,7 +47,7 @@
- .PHONY : tools man
--CFLAGS= -Wall -D_REENTRANT -O2 -g
-+CFLAGS= -Wall -D_REENTRANT $(COPTS)
- # -O3
- CC= gcc
- libjpeg= -ljpeg