htpdate: moved to github
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 19 Nov 2015 20:51:28 +0000 (20:51 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 19 Nov 2015 20:51:28 +0000 (20:51 +0000)
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@47523 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/htpdate/Makefile [deleted file]
net/htpdate/files/htpdate.default [deleted file]
net/htpdate/files/htpdate.init [deleted file]
net/htpdate/patches/100-adjtimex.patch [deleted file]

diff --git a/net/htpdate/Makefile b/net/htpdate/Makefile
deleted file mode 100644 (file)
index 8c1e9e3..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=htpdate
-PKG_VERSION:=1.0.4
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://www.clevervest.com/htp/archive/c/
-PKG_MD5SUM:=a13ec89839c33965794ebf53c4e690db
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/htpdate
-  SUBMENU:=Time Synchronization
-  SECTION:=net
-  CATEGORY:=Network
-  TITLE:=an HTP (Hypertext Time Protocol) implementation
-  URL:=http://www.clevervest.com/htp/
-endef
-
-define Package/htpdate/description
-       The HTTP Time Protocol (HTP) is used to synchronize a computer's time
-       with web servers as reference time source. Htpdate will synchronize your
-       computer's time by extracting timestamps from HTTP headers found
-       in web server responses. Htpdate can be used as a daemon, to keep your
-       computer synchronized.
-endef
-
-define Package/htpdate/conffiles
-/etc/default/htpdate
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)"
-endef
-
-define Package/htpdate/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/htpdate $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc/default/
-       $(INSTALL_CONF) ./files/htpdate.default $(1)/etc/default/htpdate
-       $(INSTALL_DIR) $(1)/etc/init.d/
-       $(INSTALL_BIN) ./files/htpdate.init $(1)/etc/init.d/htpdate
-endef
-
-$(eval $(call BuildPackage,htpdate))
-
diff --git a/net/htpdate/files/htpdate.default b/net/htpdate/files/htpdate.default
deleted file mode 100644 (file)
index 94674fd..0000000
+++ /dev/null
@@ -1 +0,0 @@
-OPTIONS="www.google.com www.yahoo.com www.linux.org www.freebsd.org"
diff --git a/net/htpdate/files/htpdate.init b/net/htpdate/files/htpdate.init
deleted file mode 100644 (file)
index 1409321..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
-
-START=49
-BIN=htpdate
-DEFAULT=/etc/default/$BIN
-RUN_D=/var/run
-PID_F=$RUN_D/$BIN.pid
-
-start() {
-       [ -f $DEFAULT ] && . $DEFAULT
-       mkdir -p $RUN_D
-       $BIN -l -s -t $OPTIONS && $BIN -D $OPTIONS
-}
-
-stop() {
-       [ -f $PID_F ] && kill $(cat $PID_F)
-}
-
diff --git a/net/htpdate/patches/100-adjtimex.patch b/net/htpdate/patches/100-adjtimex.patch
deleted file mode 100644 (file)
index ec7c8a9..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/htpdate.c
-+++ b/htpdate.c
-@@ -359,7 +359,7 @@ static int htpdate_adjtimex( double drif
-       /* Read current kernel frequency */
-       tmx.modes = 0;
--      ntp_adjtime(&tmx);
-+      adjtimex(&tmx);
-       /* Calculate new frequency */
-       freq = (long)(65536e6 * drift);
-@@ -377,7 +377,7 @@ static int htpdate_adjtimex( double drif
-               printlog( 1, "seteuid()" );
-               exit(1);
-       } else {
--              return( ntp_adjtime(&tmx) );
-+              return( adjtimex(&tmx) );
-       }
- }