luci.mk: only use remote branch detection
authorJo-Philipp Wich <jo@mein.io>
Mon, 20 Feb 2017 13:34:16 +0000 (14:34 +0100)
committerJo-Philipp Wich <jo@mein.io>
Mon, 20 Feb 2017 13:34:16 +0000 (14:34 +0100)
LEDE's scripts/feeds script creates local branches named after the checked
out commit hash, confusing local branch detection.

Solely use remote branch detection to avoid misidentifying such cases.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
luci.mk

diff --git a/luci.mk b/luci.mk
index 26f3c94f902df5556e55941c8891326cdaa34a6e..137886f1b322c75655a0276c03cfd63ed86b1aa7 100644 (file)
--- a/luci.mk
+++ b/luci.mk
@@ -70,9 +70,8 @@ PKG_VERSION?=$(if $(DUMP),x,$(strip $(shell \
 PKG_GITBRANCH?=$(if $(DUMP),x,$(strip $(shell \
        variant="LuCI"; \
        if git log -1 >/dev/null 2>/dev/null; then \
-               branch="$$(git symbolic-ref --short -q HEAD 2>/dev/null || \
-                       git branch --remote --verbose --no-abbrev --contains 2>/dev/null | \
-                               sed -e 's|^.*/||; s| .*||; q')"; \
+               branch="$$(git branch --remote --verbose --no-abbrev --contains 2>/dev/null | \
+                       sed -rne 's|^[^/]+/([^ ]+) [a-f0-9]{40} .+$$|\1|p' | head -n1)"; \
                if [ "$$branch" != "master" ]; then \
                        variant="LuCI $$branch branch"; \
                else \