convert into CMake project
[project/fwtool.git] / CMakeLists.txt
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644 (file)
index 0000000..8c449f9
--- /dev/null
@@ -0,0 +1,8 @@
+CMAKE_MINIMUM_REQUIRED(VERSION 3.0)
+
+PROJECT(fwtool C)
+INCLUDE(GNUInstallDirs)
+
+ADD_DEFINITIONS(-Wall -Werror -Wextra -Wno-unused-parameter)
+ADD_EXECUTABLE(fwtool fwtool.c)
+INSTALL(TARGETS fwtool RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})