Support larger RSA key sizes when using MBEDTLS
[project/bcm63xx/atf.git] / Makefile
index bcfbd65ed44f98bef5b79a192e3eb9d7e8375707..d1376e864f1318ba0d2318cdd7a0bb9949d9620f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -694,6 +694,10 @@ $(eval $(call assert_numeric,ARM_ARCH_MAJOR))
 $(eval $(call assert_numeric,ARM_ARCH_MINOR))
 $(eval $(call assert_numeric,BRANCH_PROTECTION))
 
+ifdef KEY_SIZE
+        $(eval $(call assert_numeric,KEY_SIZE))
+endif
+
 ifeq ($(filter $(SANITIZE_UB), on off trap),)
         $(error "Invalid value for SANITIZE_UB: can be one of on, off, trap")
 endif