AArch32: Add BL2U support
[project/bcm63xx/atf.git] / bl2u / bl2u.mk
index 7780f494ac09808cd0ed29a0fff9c6243a5857d8..b4d763433963edc90508aec0499c93f52621db77 100644 (file)
@@ -5,8 +5,11 @@
 #
 
 BL2U_SOURCES           +=      bl2u/bl2u_main.c                        \
-                               bl2u/aarch64/bl2u_entrypoint.S          \
-                               common/aarch64/early_exceptions.S       \
-                               plat/common/aarch64/platform_up_stack.S
+                               bl2u/${ARCH}/bl2u_entrypoint.S          \
+                               plat/common/${ARCH}/platform_up_stack.S
+
+ifeq (${ARCH},aarch64)
+BL2U_SOURCES           +=      common/aarch64/early_exceptions.S
+endif
 
 BL2U_LINKERFILE                :=      bl2u/bl2u.ld.S