BL31: Enable pointer authentication support
[project/bcm63xx/atf.git] / bl31 / bl31.mk
index c9ba926c591f2ae2645eaf9da6445827a4cf54f6..10feae161f06ea30701c01cd71ec80732144d490 100644 (file)
@@ -75,6 +75,10 @@ ifeq (${ENABLE_MPAM_FOR_LOWER_ELS},1)
 BL31_SOURCES           +=      lib/extensions/mpam/mpam.c
 endif
 
+ifeq (${ENABLE_PAUTH},1)
+BL31_CFLAGS            +=      -msign-return-address=non-leaf
+endif
+
 ifeq (${WORKAROUND_CVE_2017_5715},1)
 BL31_SOURCES           +=      lib/cpus/aarch64/wa_cve_2017_5715_bpiall.S      \
                                lib/cpus/aarch64/wa_cve_2017_5715_mmu.S