host-build: always define Host/Prepare/Default
[openwrt/staging/stintel.git] / include / host-build.mk
index 819fff5664087953f8ef6a5425fc251c2587dfed..235caaa6fbe8fcd96043fc034574dbb0751605ae 100644 (file)
@@ -35,13 +35,11 @@ include $(INCLUDE_DIR)/autotools.mk
 _host_target:=$(if $(HOST_QUILT),,.)
 
 Host/Patch:=$(Host/Patch/Default)
-ifneq ($(strip $(HOST_UNPACK)),)
-  define Host/Prepare/Default
-       $(HOST_UNPACK)
+define Host/Prepare/Default
+       $(if $(strip $(HOST_UNPACK)),$(HOST_UNPACK))
        [ ! -d ./src/ ] || $(CP) ./src/* $(HOST_BUILD_DIR)
        $(Host/Patch)
-  endef
-endif
+endef
 
 define Host/Prepare
   $(call Host/Prepare/Default)