same for host builds
[openwrt/openwrt.git] / include / host-build.mk
index d83446558eccbfcfac8c61a79a2921f5f564e25c..e934c91c66d9b94d068f84e81f236993669baea3 100644 (file)
@@ -84,7 +84,7 @@ ifneq ($(CONFIG_AUTOREBUILD),)
   define HostBuild/Autoclean
     $(PKG_BUILD_DIR)/.dep_files: $(STAMP_PREPARED)
     $(call rdep,${CURDIR} $(PKG_FILE_DEPEND),$(STAMP_PREPARED))
-    $(call rdep,$(PKG_BUILD_DIR),$(STAMP_BUILT),$(PKG_BUILD_DIR)/.dep_files, -and -not -path "/.*" -and -not -path "*/ipkg*")
+    $(if $(filter prepare,$(MAKECMDGOALS)),,$(call rdep,$(PKG_BUILD_DIR),$(STAMP_BUILT),$(PKG_BUILD_DIR)/.dep_files, -and -not -path "/.*" -and -not -path "*/ipkg*"))
   endef
 endif