include/image.mk: allow image code to override uImage name
[openwrt/staging/florian.git] / include / image-commands.mk
index 160b5d883395d3ef53f4c61426ea27a5dbd3a063..00cb3410e95631a7808b8a624d0ee32f0445907c 100644 (file)
@@ -7,7 +7,7 @@ define Build/uImage
        mkimage -A $(LINUX_KARCH) \
                -O linux -T kernel \
                -C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
-               -n '$(call toupper,$(LINUX_KARCH)) LEDE Linux-$(LINUX_VERSION)' -d $@ $@.new
+               -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) LEDE Linux-$(LINUX_VERSION))' -d $@ $@.new
        @mv $@.new $@
 endef