build: image: add pad-to and pad-rootfs-squashfs helpers
[openwrt/staging/lynxis.git] / include / image-commands.mk
index 8251a814000d2507676ccf51075860e86f64da18..06c084c48b0eeb54c15a69569dc84beaa8da8ff8 100644 (file)
@@ -230,8 +230,7 @@ define Build/append-uboot
 endef
 
 define Build/pad-to
-       dd if=$@ of=$@.new bs=$(1) conv=sync
-       mv $@.new $@
+       $(call Image/pad-to,$@,$(1))
 endef
 
 define Build/pad-extra