image: pass device blocksize to padjffs2
[openwrt/staging/yousong.git] / include / image-commands.mk
index 6cb5bff4ab79008b5f5a7f547ea2fd0246fc7d45..9db150c9050954813f8b1c13a2702d955d27a37c 100644 (file)
@@ -131,7 +131,8 @@ define Build/pad-to
 endef
 
 define Build/pad-rootfs
-       $(STAGING_DIR_HOST)/bin/padjffs2 $@ $(1) 4 8 16 64 128 256
+       $(STAGING_DIR_HOST)/bin/padjffs2 $@ $(1) \
+               $(if $(BLOCKSIZE),$(BLOCKSIZE:%k=%),4 8 16 64 128 256)
 endef
 
 define Build/pad-offset