build: drop cameo-factory recipe
[openwrt/staging/chunkeey.git] / include / image-commands.mk
index 4e93115963bf1b5e71c252fff7d420fec8fcc376..5e24c5e3aac39f63041b20f0d19ace1b20e39bea 100644 (file)
@@ -44,30 +44,6 @@ define Build/buffalo-dhp-image
        mv $@.new $@
 endef
 
-# blow up binary to given size and put a given string at its end:
-# cameo-factory <size[k]> <string>
-define Build/cameo-factory
-       factory_stamp=$(word 2,$(1)); \
-       ((reduced_size=$(subst k,*1024,$(word 1,$(1)))-$${#factory_stamp})); \
-       ( \
-               dd if=$@ bs=$$reduced_size conv=sync; \
-               echo -n $$factory_stamp; \
-       ) > $@.new && \
-       mv $@.new $@
-endef
-
-# blow up binary to given size and put a given string at its end:
-# cameo-factory <size[k]> <string>
-define Build/cameo-factory
-       factory_stamp=$(word 2,$(1)); \
-       ((reduced_size=$(subst k,*1024,$(word 1,$(1)))-$${#factory_stamp})); \
-       ( \
-               dd if=$@ bs=$$reduced_size conv=sync; \
-               echo -n $$factory_stamp; \
-       ) > $@.new && \
-       mv $@.new $@
-endef
-
 define Build/eva-image
        $(STAGING_DIR_HOST)/bin/lzma2eva $(KERNEL_LOADADDR) $(KERNEL_LOADADDR) $@ $@.new
        mv $@.new $@
@@ -114,6 +90,10 @@ define Build/append-squashfs-fakeroot-be
        cat $@.fakesquashfs >> $@
 endef
 
+define Build/append-string
+       echo -n $(1) >> $@
+endef
+
 # append a fake/empty uImage header, to fool bootloaders rootfs integrity check
 # for example
 define Build/append-uImage-fakehdr