kernel: bump 5.4 to 5.4.64
[openwrt/openwrt.git] / include / image-commands.mk
index ade370cc0dacec90c0ee6e0d53b89fc051e9ad4b..9516801c8dfd596e5f2c251b15c013c2a26e0642 100644 (file)
@@ -3,6 +3,10 @@
 IMAGE_KERNEL = $(word 1,$^)
 IMAGE_ROOTFS = $(word 2,$^)
 
+define rootfs_align
+$(patsubst %-256k,0x40000,$(patsubst %-128k,0x20000,$(patsubst %-64k,0x10000,$(patsubst squashfs%,0x4,$(patsubst root.%,%,$(1))))))
+endef
+
 define Build/uImage
        mkimage -A $(LINUX_KARCH) \
                -O linux -T kernel \
@@ -109,10 +113,13 @@ endef
 # append a fake/empty uImage header, to fool bootloaders rootfs integrity check
 # for example
 define Build/append-uImage-fakehdr
+       $(eval type=$(word 1,$(1)))
+       $(eval magic=$(word 2,$(1)))
        touch $@.fakehdr
        $(STAGING_DIR_HOST)/bin/mkimage \
-               -A $(LINUX_KARCH) -O linux -T $(1) -C none \
-               -n '$(VERSION_DIST) fake $(1)' \
+               -A $(LINUX_KARCH) -O linux -T $(type) -C none \
+               -n '$(VERSION_DIST) fake $(type)' \
+               $(if $(magic),-M $(magic)) \
                -d $@.fakehdr \
                -s \
                $@.fakehdr
@@ -120,7 +127,7 @@ define Build/append-uImage-fakehdr
 endef
 
 define Build/tplink-safeloader
-       -$(STAGING_DIR_HOST)/bin/tplink-safeloader \
+       -$(STAGING_DIR_HOST)/bin/tplink-safeloader \
                -B $(TPLINK_BOARD_ID) \
                -V $(REVISION) \
                -k $(IMAGE_KERNEL) \
@@ -136,10 +143,13 @@ define Build/append-dtb
 endef
 
 define Build/install-dtb
-       $(foreach dts,$(DEVICE_DTS), \
-               $(CP) \
-                       $(DTS_DIR)/$(dts).dtb \
-                       $(BIN_DIR)/$(IMG_PREFIX)-$(dts).dtb; \
+       $(call locked, \
+               $(foreach dts,$(DEVICE_DTS), \
+                       $(CP) \
+                               $(DTS_DIR)/$(dts).dtb \
+                               $(BIN_DIR)/$(IMG_PREFIX)-$(dts).dtb; \
+               ), \
+               install-dtb-$(IMG_PREFIX) \
        )
 endef
 
@@ -230,8 +240,7 @@ define Build/append-uboot
 endef
 
 define Build/pad-to
-       dd if=$@ of=$@.new bs=$(1) conv=sync
-       mv $@.new $@
+       $(call Image/pad-to,$@,$(1))
 endef
 
 define Build/pad-extra
@@ -260,8 +269,10 @@ define Build/xor-image
 endef
 
 define Build/check-size
-       @[ $$(($(subst k,* 1024,$(subst m, * 1024k,$(1))))) -ge "$$(stat -c%s $@)" ] || { \
-               echo "WARNING: Image file $@ is too big" >&2; \
+       @imagesize="$$(stat -c%s $@)"; \
+       limitsize="$$(($(subst k,* 1024,$(subst m, * 1024k,$(if $(1),$(1),$(IMAGE_SIZE))))))"; \
+       [ $$limitsize -ge $$imagesize ] || { \
+               echo "WARNING: Image file $@ is too big: $$imagesize > $$limitsize" >&2; \
                rm -f $@; \
        }
 endef
@@ -330,6 +341,24 @@ define Build/tplink-v1-header
        @mv $@.new $@
 endef
 
+# combine kernel and rootfs into one image
+# mktplinkfw <type> <optional extra arguments to mktplinkfw binary>
+# <type> is "sysupgrade" or "factory"
+#
+# -a align the rootfs start on an <align> bytes boundary
+# -j add jffs2 end-of-filesystem markers
+# -s strip padding from end of the image
+# -X reserve <size> bytes in the firmware image (hexval prefixed with 0x)
+define Build/tplink-v1-image
+       -$(STAGING_DIR_HOST)/bin/mktplinkfw \
+               -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) \
+               -N "$(VERSION_DIST)" -V $(REVISION) -m $(TPLINK_HEADER_VERSION) \
+               -k $(IMAGE_KERNEL) -r $(IMAGE_ROOTFS) -o $@.new -j -X 0x40000 \
+               -a $(call rootfs_align,$(FILESYSTEM)) \
+               $(wordlist 2,$(words $(1)),$(1)) \
+               $(if $(findstring sysupgrade,$(word 1,$(1))),-s) && mv $@.new $@ || rm -f $@
+endef
+
 define Build/tplink-v2-header
        $(STAGING_DIR_HOST)/bin/mktplinkfw2 \
                -c -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -L $(KERNEL_LOADADDR) \
@@ -350,22 +379,35 @@ define Build/tplink-v2-image
        rm -rf $@.new
 endef
 
+compat_version=$(if $(DEVICE_COMPAT_VERSION),$(DEVICE_COMPAT_VERSION),1.0)
 json_quote=$(subst ','\'',$(subst ",\",$(1)))
 #")')
+
+legacy_supported_message=$(SUPPORTED_DEVICES) - Image version mismatch: image $(compat_version), \
+       device 1.0. Please wipe config during upgrade (force required) or reinstall. \
+       $(if $(DEVICE_COMPAT_MESSAGE),Reason: $(DEVICE_COMPAT_MESSAGE),Please check documentation ...)
+
 metadata_devices=$(if $(1),$(subst "$(space)","$(comma)",$(strip $(foreach v,$(1),"$(call json_quote,$(v))"))))
 metadata_json = \
        '{ $(if $(IMAGE_METADATA),$(IMAGE_METADATA)$(comma)) \
-               "supported_devices":[$(call metadata_devices,$(1))], \
+               "metadata_version": "1.1", \
+               "compat_version": "$(call json_quote,$(compat_version))", \
+               $(if $(DEVICE_COMPAT_MESSAGE),"compat_message": "$(call json_quote,$(DEVICE_COMPAT_MESSAGE))"$(comma)) \
+               $(if $(filter-out 1.0,$(compat_version)),"new_supported_devices": \
+                       [$(call metadata_devices,$(SUPPORTED_DEVICES))]$(comma) \
+                       "supported_devices": ["$(call json_quote,$(legacy_supported_message))"]$(comma)) \
+               $(if $(filter 1.0,$(compat_version)),"supported_devices":[$(call metadata_devices,$(SUPPORTED_DEVICES))]$(comma)) \
                "version": { \
                        "dist": "$(call json_quote,$(VERSION_DIST))", \
                        "version": "$(call json_quote,$(VERSION_NUMBER))", \
                        "revision": "$(call json_quote,$(REVISION))", \
-                       "board": "$(call json_quote,$(BOARD))" \
+                       "target": "$(call json_quote,$(TARGETID))", \
+                       "board": "$(call json_quote,$(if $(BOARD_NAME),$(BOARD_NAME),$(DEVICE_NAME)))" \
                } \
        }'
 
 define Build/append-metadata
-       $(if $(SUPPORTED_DEVICES),-echo $(call metadata_json,$(SUPPORTED_DEVICES)) | fwtool -I - $@)
+       $(if $(SUPPORTED_DEVICES),-echo $(call metadata_json) | fwtool -I - $@)
        [ ! -s "$(BUILD_KEY)" -o ! -s "$(BUILD_KEY).ucert" -o ! -s "$@" ] || { \
                cp "$(BUILD_KEY).ucert" "$@.ucert" ;\
                usign -S -m "$@" -s "$(BUILD_KEY)" -x "$@.sig" ;\
@@ -378,3 +420,10 @@ define Build/kernel2minor
        kernel2minor -k $@ -r $@.new $(1)
        mv $@.new $@
 endef
+
+# Convert a raw image into a $1 type image.
+# E.g. | qemu-image vdi
+define Build/qemu-image
+       qemu-img convert -f raw -O $1 $@ $@.new
+       @mv $@.new $@
+endef