include: use cpio from staging dir
[openwrt/staging/rmilecki.git] / include / image.mk
index 48911e4057b7f6e6aa729cc7608eec3b6c35d5ad..7f0d27b74643f4316cbb6ce6ebfc29d1b7514a39 100644 (file)
@@ -301,7 +301,7 @@ endif
 
 ifdef CONFIG_TARGET_ROOTFS_CPIOGZ
   define Image/Build/cpiogz
-       ( cd $(TARGET_DIR); find . | cpio -o -H newc -R root:root | gzip -9n >$(BIN_DIR)/$(IMG_ROOTFS).cpio.gz )
+       ( cd $(TARGET_DIR); find . | $(STAGING_DIR_HOST)/bin/cpio -o -H newc -R root:root | gzip -9n >$(BIN_DIR)/$(IMG_ROOTFS).cpio.gz )
   endef
 endif