build: kernel: avoid unnecessary package rebuilds
[openwrt/staging/mkresin.git] / include / kernel-defaults.mk
index f2864d6a10ff102d93225d8b14d74c34479ee856..77a612dbe1b88e6256cdf89386557c6907b9f7db 100644 (file)
@@ -128,6 +128,10 @@ endef
 define Kernel/CompileModules/Default
        rm -f $(LINUX_DIR)/vmlinux $(LINUX_DIR)/System.map
        +$(KERNEL_MAKE) $(if $(KERNELNAME),$(KERNELNAME),all) modules
+       # If .config did not change, use the previous timestamp to avoid package rebuilds
+       cmp -s $(LINUX_DIR)/.config $(LINUX_DIR)/.config.modules.save && \
+               mv $(LINUX_DIR)/.config.modules.save $(LINUX_DIR)/.config; \
+       $(CP) $(LINUX_DIR)/.config $(LINUX_DIR)/.config.modules.save
 endef
 
 OBJCOPY_STRIP = -R .reginfo -R .notes -R .note -R .comment -R .mdebug -R .note.gnu.build-id