include the kernel config for kernel related packages (should fix some b43 compile...
[openwrt/svn-archive/archive.git] / include / kernel.mk
index b82668ea48d1755d6fada59b7b07788e8ad75083..460269949b1422b2fcf1165354a9fa3fbc275ad2 100644 (file)
@@ -23,11 +23,11 @@ else
   endif
 
   ifneq (,$(findstring uml,$(BOARD)))
-    KERNEL_CC:=$(HOSTCC)
-    KERNEL_CROSS:=
+    KERNEL_CC?=$(HOSTCC)
+    KERNEL_CROSS?=
   else
-    KERNEL_CC:=$(TARGET_CC)
-    KERNEL_CROSS:=$(TARGET_CROSS)
+    KERNEL_CC?=$(TARGET_CC)
+    KERNEL_CROSS?=$(TARGET_CROSS)
   endif
 
   PATCH_DIR ?= ./patches$(shell [ -d "./patches-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )
@@ -43,19 +43,22 @@ else
   TESTING:=$(if $(findstring -rc,$(LINUX_VERSION)),/testing,)
   LINUX_SITE:=@KERNEL/linux/kernel/v$(KERNEL)$(TESTING) \
 
-  PKG_BUILD_DIR ?= $(KERNEL_BUILD_DIR)/$(PKG_NAME)$(if $(PKG_VERSION),-$(PKG_VERSION))
+  ifneq ($(TARGET_BUILD),1)
+    PKG_BUILD_DIR ?= $(KERNEL_BUILD_DIR)/$(PKG_NAME)$(if $(PKG_VERSION),-$(PKG_VERSION))
+  endif
 endif
 
 ifneq (,$(findstring uml,$(BOARD)))
   LINUX_KARCH:=um
 else
-  LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
-       -e 's/mipsel/mips/' \
-       -e 's/mipseb/mips/' \
-       -e 's/powerpc/ppc/' \
-       -e 's/sh[234]/sh/' \
-       -e 's/armeb/arm/' \
-  )
+  ifeq (,$(LINUX_KARCH))
+    LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
+         -e 's/mipsel/mips/' \
+         -e 's/mipseb/mips/' \
+         -e 's/sh[234]/sh/' \
+         -e 's/armeb/arm/' \
+    )
+  endif
 endif
 
 
@@ -85,7 +88,10 @@ define ModuleAutoLoad
                chmod 0755 $(2)/CONTROL/postinst; \
        fi
 endef
+
+ifeq ($(DUMP),)
+  -include $(LINUX_DIR)/.config
+endif
 
 define KernelPackage
   NAME:=$(1)
@@ -113,8 +119,7 @@ $(call KernelPackage/$(1)/description)
     endef
   endif
 
-  # check that all CONFIG_* symbols in $(KCONFIG) are set to 'm'
-  ifeq ($(filter-out m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$(if $($(c)),$($(c)),n))),)
+  ifneq ($(if $(KCONFIG),$(filter m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
     ifneq ($(strip $(FILES)),)
       define Package/kmod-$(1)/install
                  mkdir -p $$(1)/lib/modules/$(LINUX_VERSION)
@@ -123,6 +128,12 @@ $(call KernelPackage/$(1)/description)
                  $(call KernelPackage/$(1)/install,$$(1))
       endef
     endif
+  $(if $(CONFIG_PACKAGE_kmod-$(1)),
+    else
+      compile: kmod-$(1)-unavailable
+      kmod-$(1)-unavailable:
+               @echo "WARNING: kmod-$(1) is not available in the kernel config"
+  )
   endif
   $$(eval $$(call BuildPackage,kmod-$(1)))