build: introduce extra targets that contain only proper dependencies
[openwrt/staging/lynxis/omap.git] / include / package.mk
index 62e538c5945fdb9af02d12ce94cca8f57159d8a7..37cea1448df8339f9eb2d325bbac70b04dc537ad 100644 (file)
@@ -204,13 +204,13 @@ define Build/CoreTargets
        touch $$@
 
   ifdef Build/InstallDev
-    compile: $(STAMP_INSTALLED)
+    .compile: $(STAMP_INSTALLED)
   endif
 
-  prepare: $(STAMP_PREPARED)
-  configure: $(STAMP_CONFIGURED)
-  dist: $(STAMP_CONFIGURED)
-  distcheck: $(STAMP_CONFIGURED)
+  .prepare: $(STAMP_PREPARED)
+  .configure: $(STAMP_CONFIGURED)
+  .dist: $(STAMP_CONFIGURED)
+  .distcheck: $(STAMP_CONFIGURED)
 endef
 
 define Build/DefaultTargets
@@ -289,6 +289,7 @@ $(PACKAGE_DIR):
        mkdir -p $@
 
 compile: prepare-package-install
+.install: .compile
 install: compile
 
 clean: FORCE