build: add a config knob to enable gc-sections for all packages
[openwrt/staging/jow.git] / include / package.mk
index 0fb947f035c21d3177cb5b99923b2739722fb8bc..687f74edc1cf1b7b82d0462b488e163056759512 100644 (file)
@@ -51,7 +51,7 @@ ifdef CONFIG_USE_MIPS16
     TARGET_CXXFLAGS += -mips16 -minterlink-mips16
   endif
 endif
-ifeq ($(call pkg_build_flag,gc-sections,0),1)
+ifeq ($(call pkg_build_flag,gc-sections,$(if $(CONFIG_USE_GC_SECTIONS),1,0)),1)
   TARGET_CFLAGS+= -ffunction-sections -fdata-sections
   TARGET_CXXFLAGS+= -ffunction-sections -fdata-sections
   TARGET_LDFLAGS+= -Wl,--gc-sections