build: replace `true` with a custom noop script
[openwrt/staging/stintel.git] / include / prereq-build.mk
index e5f20fff22e282b0dd72f3b951b3becf5af30308..49340ce3e441ccbaa1833d6eb38d8abd450f627e 100644 (file)
@@ -238,4 +238,4 @@ prereq: $(STAGING_DIR_HOST)/bin/mkhash $(STAGING_DIR_HOST)/bin/xxd
 
 # Install ldconfig stub
 $(eval $(call TestHostCommand,ldconfig-stub,Failed to install stub, \
-       $(LN) $(firstword $(wildcard /bin/true /usr/bin/true)) $(STAGING_DIR_HOST)/bin/ldconfig))
+       $(LN) $(SCRIPT_DIR)/noop.sh $(STAGING_DIR_HOST)/bin/ldconfig))