build: prereq: add support for Python 3.8
[openwrt/staging/rmilecki.git] / include / prereq-build.mk
index d73f0040c357dc1b35ee41dee2f0f5a73bdbc712..a711ae33f7edd9d5ec494fc4d0e0e6a363a7ed85 100644 (file)
@@ -144,12 +144,14 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
 $(eval $(call CleanupPython2))
 
 $(eval $(call SetupHostCommand,python,Please install Python >= 3.5, \
+       python3.8 -V 2>&1 | grep 'Python 3', \
        python3.7 -V 2>&1 | grep 'Python 3', \
        python3.6 -V 2>&1 | grep 'Python 3', \
        python3.5 -V 2>&1 | grep 'Python 3', \
        python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
 
 $(eval $(call SetupHostCommand,python3,Please install Python >= 3.5, \
+       python3.8 -V 2>&1 | grep 'Python 3', \
        python3.7 -V 2>&1 | grep 'Python 3', \
        python3.6 -V 2>&1 | grep 'Python 3', \
        python3.5 -V 2>&1 | grep 'Python 3', \