prereq-build: fix inconsistent value of $PATH
[openwrt/staging/jow.git] / include / prereq.mk
index 74c3914d060da3566caccb34f3aa7682050ed5ba..45c84e984c6f2942ac34b7b2a5153bcfcf8969ac 100644 (file)
@@ -28,9 +28,9 @@ define Require
 
     prereq-$(1): $(if $(PREREQ_PREV),prereq-$(PREREQ_PREV)) FORCE
                printf "Checking '$(1)'... "
-               if $(NO_TRACE_MAKE) -f $(firstword $(MAKEFILE_LIST)) check-$(1) >/dev/null 2>/dev/null; then \
+               if $(NO_TRACE_MAKE) -f $(firstword $(MAKEFILE_LIST)) check-$(1) PATH="$(ORIG_PATH)" >/dev/null 2>/dev/null; then \
                        echo 'ok.'; \
-               elif $(NO_TRACE_MAKE) -f $(firstword $(MAKEFILE_LIST)) check-$(1) >/dev/null 2>/dev/null; then \
+               elif $(NO_TRACE_MAKE) -f $(firstword $(MAKEFILE_LIST)) check-$(1) PATH="$(ORIG_PATH)" >/dev/null 2>/dev/null; then \
                        echo 'updated.'; \
                else \
                        echo 'failed.'; \
@@ -104,8 +104,7 @@ define SetupHostCommand
                   $(call QuoteHostCommand,$(9)) $(call QuoteHostCommand,$(10)) \
                   $(call QuoteHostCommand,$(11)) $(call QuoteHostCommand,$(12)); do \
                if [ -n "$$$$$$$$cmd" ]; then \
-                       bin="$$$$$$$$(PATH="$(subst $(space),:,$(filter-out $(STAGING_DIR_HOST)/%,$(subst :,$(space),$(PATH))))" \
-                               command -v "$$$$$$$${cmd%% *}")"; \
+                       bin="$$$$$$$$(command -v "$$$$$$$${cmd%% *}")"; \
                        if [ -x "$$$$$$$$bin" ] && eval "$$$$$$$$cmd" >/dev/null 2>/dev/null; then \
                                case "$$$$$$$$(ls -dl -- $(STAGING_DIR_HOST)/bin/$(strip $(1)))" in \
                                        *" -> $$$$$$$$bin"*) \