rootfs: fix USE_APK detection
[openwrt/staging/pepe2k.git] / include / rootfs.mk
index eb4fa434a365101f63970db7057e2d4487ad81f0..907a95a794a34af71e86a4c6eb9c4b1ec6109e33 100644 (file)
@@ -78,7 +78,7 @@ define prepare_rootfs
        @mkdir -p $(1)/var/lock
        @( \
                cd $(1); \
-               if [ -n $(CONFIG_USE_APK) ]; then \
+               if [ -n "$(CONFIG_USE_APK)" ]; then \
                $(STAGING_DIR_HOST)/bin/tar -xf ./lib/apk/db/scripts.tar --wildcards "*.post-install" -O > script.sh; \
                chmod +x script.sh; \
                IPKG_INSTROOT=$(1) $$(command -v bash) script.sh; \