build: conditionally enable testing-kernel feature
[openwrt/staging/mkresin.git] / include / target.mk
index a2ceb7f783f363e6a40598161c68f245a155d5df..64292138b7ad1548819bce16c734e1fbbffd1c43 100644 (file)
@@ -223,7 +223,9 @@ ifeq ($(DUMP),1)
     .PRECIOUS: $(TMP_CONFIG)
 
     ifdef KERNEL_TESTING_PATCHVER
-      FEATURES += testing-kernel
+      ifneq ($(KERNEL_TESTING_PATCHVER),$(KERNEL_PATCHVER))
+        FEATURES += testing-kernel
+      endif
     endif
     ifneq ($(CONFIG_OF),)
       FEATURES += dt