build: add APK package build capabilities
[openwrt/staging/stintel.git] / include / target.mk
index 68558601f33c4f31a7a2e945b35fabc17a36e157..8b81b54624869b02af444009c0fcafec14acef51 100644 (file)
@@ -21,12 +21,17 @@ DEFAULT_PACKAGES:=\
        logd \
        mtd \
        netifd \
-       opkg \
        uci \
        uclient-fetch \
        urandom-seed \
        urngd
 
+ifdef CONFIG_USE_APK
+DEFAULT_PACKAGES+=apk
+else
+DEFAULT_PACKAGES+=opkg
+endif
+
 ifneq ($(CONFIG_SELINUX),)
 DEFAULT_PACKAGES+=busybox-selinux procd-selinux
 else