buildsystem: add CONFIG_SECCOMP
[openwrt/openwrt.git] / include / target.mk
index 7526224972e18148fec8a12318ca7f90a382475f..60760bf60242d849e67f7d4f30314f3d3b3a5ac9 100644 (file)
@@ -33,6 +33,16 @@ else
 DEFAULT_PACKAGES+=busybox procd
 endif
 
+# include ujail on systems with enough storage
+ifeq ($(CONFIG_SMALL_FLASH),)
+DEFAULT_PACKAGES+=procd-ujail
+endif
+
+# include seccomp ld-preload hooks if kernel supports it
+ifneq ($(CONFIG_SECCOMP),)
+DEFAULT_PACKAGES+=procd-seccomp
+endif
+
 # For the basic set
 DEFAULT_PACKAGES.basic:=
 # For nas targets