u-boot.mk: always link host libraries static
[openwrt/staging/jow.git] / include / u-boot.mk
index 8c6941b88ac5d99b4338405c7de50b83bdeec3e1..509b3d76dc54064965a15df5356a4fbbdb6d0d5e 100644 (file)
@@ -48,6 +48,7 @@ UBOOT_MAKE_FLAGS = \
        STAGING_PREFIX="$(STAGING_DIR_HOST)" \
        PKG_CONFIG_PATH="$(STAGING_DIR_HOST)/lib/pkgconfig" \
        PKG_CONFIG_LIBDIR="$(STAGING_DIR_HOST)/lib/pkgconfig" \
+       PKG_CONFIG_EXTRAARGS="--static" \
        $(if $(findstring c,$(OPENWRT_VERBOSE)),V=1,V='')
 
 define Build/U-Boot/Target