luarocks: Fix seeded uname (s/m) in siteconfig
[feed/packages.git] / lang / luarocks / Makefile
index 7519f8f7c806cbd7abf53bf3422b0f4b260d84c8..b8b89ae99eeb30e6bafbc624f994de9b16e3c37e 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=luarocks
 PKG_VERSION:=2.2.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_PROTO:=git
@@ -43,6 +43,10 @@ CONFIGURE_ARGS = \
     --sysconfdir=/etc \
     --with-lua=$(STAGING_DIR)/host
 
+CONFIGURE_VARS = \
+       LUAROCKS_UNAME_S="Linux" \
+       LUAROCKS_UNAME_M="$(ARCH)"
+
 define Build/Compile
        $(call Build/Compile/Default,build)
 endef