node-arduino-firmata: fix issues with node 8.11.3
[feed/packages.git] / lang / node-arduino-firmata / Makefile
index d8ce58861c179e8e586a6c498f9f43946f225c95..694183d66e5bfb5d39b10d463098fc043fa2c37a 100644 (file)
@@ -10,17 +10,17 @@ include $(TOPDIR)/rules.mk
 PKG_NPM_NAME:=arduino-firmata
 PKG_NAME:=node-$(PKG_NPM_NAME)
 PKG_VERSION:=0.3.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/shokai/node-arduino-firmata.git
+PKG_MIRROR_HASH:=1aef93dc704ea771b9eab51cb64103533f829aee5b2886ad55d173adf3f11ede
 PKG_SOURCE_VERSION:=v0.3.4
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_SOURCE_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.gz
-#PKG_MIRROR_HASH:=b7a498ccf70e466503e72d38ae5b474e91416b6c9842fd167dff249357b0dc37
 
 PKG_BUILD_DEPENDS:=node/host
-PKG_NODE_VERSION:=8.10.0
+PKG_NODE_VERSION:=`$(STAGING_DIR_HOSTPKG)/bin/node --version`
 
 PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
 PKG_LICENSE:=MIT
@@ -51,16 +51,25 @@ EXTRA_LDFLAGS="-L$(TOOLCHAIN_DIR)/lib/ -Wl,-rpath-link $(TOOLCHAIN_DIR)/lib/" \
 define Build/Compile
        $(MAKE_FLAGS) \
        npm_config_arch=$(CONFIG_ARCH) \
-       npm_config_nodedir=$(BUILD_DIR)/node-v$(PKG_NODE_VERSION)/ \
-       npm_config_cache=$(BUILD_DIR)/node-v$(PKG_NODE_VERSION)/npm-cache \
+       npm_config_nodedir=$(BUILD_DIR)/node-$(PKG_NODE_VERSION)/ \
+       npm_config_cache=$(BUILD_DIR)/node-$(PKG_NODE_VERSION)/npm-cache \
        PREFIX="$(PKG_INSTALL_DIR)/usr/" \
        npm install -g $(PKG_BUILD_DIR)
 endef
 
 define Package/node-arduino-firmata/install
        mkdir -p $(1)/usr/lib/node
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/node_modules/ $(1)/usr/lib/node
-       rm -rf $(1)/usr/lib/node/arduino-firmata/node_modules/serialport/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/node_modules/. $(1)/usr/lib/node
+       rm -rf  $(1)/usr/lib/node/arduino-firmata/node_modules/serialport/ \
+               $(1)/usr/lib/node/arduino-firmata/patches \
+               $(1)/usr/lib/node/arduino-firmata/.p* \
+               $(1)/usr/lib/node/arduino-firmata/.quilt* \
+               $(1)/usr/lib/node/arduino-firmata/.built* \
+               $(1)/usr/lib/node/arduino-firmata/.config*
+       # Strip PKG_BUILD_DIR from useless metadata inserted by npm install
+       # https://github.com/npm/npm/issues/10393
+       # https://github.com/npm/npm/issues/12110
+       find $(1)/usr/lib/node -name package.json -exec sed -i -e 's,$(PKG_BUILD_DIR),,g' {} +
        $(CP) ./files/* $(1)/
 endef