python-packages: Clean up Makefiles
[feed/packages.git] / lang / python / python-pyasn1-modules / Makefile
index 5eafbfef400cc00bfa39e2133c216c5291e575c2..8d82aa8cfc7ef7877128a5b4c8b8bd3087c80fd4 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-pyasn1-modules
 PKG_VERSION:=0.2.8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PYPI_NAME:=pyasn1-modules
 PKG_HASH:=905f84c712230b2c592c19470d3ca8d552de726050d1d1716282a1f6146be65e
@@ -22,27 +22,20 @@ include ../pypi.mk
 include $(INCLUDE_DIR)/package.mk
 include ../python3-package.mk
 
-define Package/python-pyasn1-modules/Default
+define Package/python3-pyasn1-modules
   SECTION:=lang
   CATEGORY:=Languages
   SUBMENU:=Python
   TITLE:=Collection of ASN.1 modules
   URL:=https://github.com/etingof/pyasn1-modules
-endef
-
-define Package/python3-pyasn1-modules
-$(call Package/python-pyasn1-modules/Default)
   DEPENDS:= \
-      +PACKAGE_python3-pyasn1-modules:python3-light \
-      +PACKAGE_python3-pyasn1-modules:python3-pyasn1
-  VARIANT:=python3
+      +python3-light \
+      +python3-pyasn1
 endef
 
 define Package/python3-pyasn1-modules/description
 This is a small but growing collection of ASN.1 data structures
 expressed in Python terms using pyasn1 data model.
-.
-(Variant for Python3).
 endef
 
 $(eval $(call Py3Package,python3-pyasn1-modules))