Merge pull request #278 from micmac1/dahdi-linux-flags
[feed/telephony.git] / libs / dahdi-tools / Makefile
index 05fef5421cef5f0c9b18cb4eb938a365c4c59e00..5ad82a8e5dce696c71d0f562d671967ed9f87b7d 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2014 OpenWrt.org
+# Copyright (C) 2014 - 2018 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dahdi-tools
 PKG_VERSION:=2.11.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://downloads.asterisk.org/pub/telephony/dahdi-tools/releases
@@ -46,20 +46,12 @@ define Package/dahdi-tools-libtonezone
   TITLE:=DAHDI tonezone library
 endef
 
-TARGET_CFLAGS += $(FPIC)
-EXTRA_CFLAGS:= $(TARGET_CPPFLAGS)
-
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
                HOSTCC="$(HOSTCC)" \
                CROSS_COMPILE="$(TARGET_CROSS)" \
-               CFLAGS="$(TARGET_CFLAGS) -I. -DBUILDING_TONEZONE -I$(STAGING_DIR)/usr/include" \
-               KSRC="$(LINUX_DIR)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
-               DAHDI_INCLUDE="$(STAGING_DIR)/usr/include" \
-               CONFIGURE_SILENT="--silent" \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="$(TARGET_CPPFLAGS)" \
                dahdi_cfg dahdi_monitor dahdi_scan dahdi_speed dahdi_test fxotune
 endef
 
@@ -69,27 +61,26 @@ define Build/InstallDev
        $(CP) $(PKG_BUILD_DIR)/.libs/*.a $(1)/usr/lib/
 
        $(INSTALL_DIR) $(1)/usr/include/dahdi
-       $(CP) $(PKG_BUILD_DIR)/tonezone.h $(1)/usr/include/dahdi/
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/tonezone.h $(1)/usr/include/dahdi/
 endef
 
 define Package/dahdi-cfg/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/.libs/dahdi_cfg $(1)/usr/sbin/
-       $(CP) $(PKG_BUILD_DIR)/dahdi_scan $(1)/usr/sbin/
-       $(CP) $(PKG_BUILD_DIR)/fxotune $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/.libs/dahdi_cfg $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/dahdi_scan $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/fxotune $(1)/usr/sbin/
 endef
 
 define Package/dahdi-monitor/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/dahdi_monitor $(1)/usr/sbin/
-       $(CP) $(PKG_BUILD_DIR)/dahdi_speed $(1)/usr/sbin/
-       $(CP) $(PKG_BUILD_DIR)/dahdi_test $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/dahdi_monitor $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/dahdi_speed $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/dahdi_test $(1)/usr/sbin/
 endef
 
 define Package/dahdi-tools-libtonezone/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/.libs/libtonezone.so.2.0.0 $(1)/usr/lib/
-       cd $(1)/usr/lib/; ln -s libtonezone.so.2.0.0 libtonezone.so; ln -s libtonezone.so.2.0.0 libtonezone.so.2
+       $(CP) $(PKG_BUILD_DIR)/.libs/libtonezone.so* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,dahdi-cfg))