freetype: add host config flags
[feed/packages.git] / libs / freetype / Makefile
index d7a4ae9ebfdba01c7a3b231f64a74516b286104a..2865b615bfa1a892f64e929ace712a59c38be6ff 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=freetype
 PKG_VERSION:=2.9.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/freetype
@@ -51,6 +51,11 @@ CONFIGURE_ARGS += \
        --with-zlib=yes \
        --with-png=yes
 
+HOST_CONFIGURE_ARGS+= \
+       --with-bzip2=no \
+       --with-zlib=no \
+       --with-png=no
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
 endef