libevhtp: Fix dependencies not selected when building static library
[feed/packages.git] / libs / libevhtp / Makefile
index ee1b02d20bfbcc09144cc5aeb36a7ab24ede17a8..772c6d5bcc8f8e35db2852d55be3d0546cdd39fe 100644 (file)
@@ -12,7 +12,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libevhtp
 PKG_VERSION:=1.2.18
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 # This package is building a static library, used by seafile-server
 # Every time the built library changes (metadata changes are exempt),
 # seafile-server needs a release bump to ensure the update is used.
@@ -21,12 +21,15 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/criticalstack/libevhtp/tar.gz/$(PKG_VERSION)?
 PKG_HASH:=316ede0d672be3ae6fe489d4ac1c8c53a1db7d4fe05edaff3c7c853933e02795
 
-PKG_MAINTAINER:=Eneas U de Queiroz <cote2004-github@yahoo.com>
+PKG_MAINTAINER:=Eneas U de Queiroz <cotequeiroz@gmail.com>, Jeffery To <jeffery.to@gmail.com>
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=LICENSE
 
+PKG_BUILD_DEPENDS:=libevent2 oniguruma
 CMAKE_INSTALL:=1
 
+PKG_CONFIG_DEPENDS:=LIBEVHTP_BUILD_DEPENDS
+
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
 
@@ -35,7 +38,6 @@ define Package/libevhtp
     CATEGORY:=Libraries
     TITLE:=A more flexible replacement for libevent's httpd API
     URL:=https://github.com/criticalstack/libevhtp
-    DEPENDS:=+libevent2 +libevent2-openssl +libevent2-pthreads +oniguruma
 endef
 
 define Package/libevhtp/description
@@ -44,6 +46,18 @@ define Package/libevhtp/description
    meaning the developer never thought of it being used for creating a full-fledged HTTP service.
 endef
 
+define Package/libevhtp/config
+config LIBEVHTP_BUILD_DEPENDS
+       bool
+       default PACKAGE_libevhtp
+
+config LIBEVHTP_BUILD_SELECT
+       tristate
+       default m if LIBEVHTP_BUILD_DEPENDS
+       select PACKAGE_libevent2-openssl
+       select PACKAGE_libevent2-pthreads
+endef
+
 define Build/InstallDev
        $(call Build/InstallDev/cmake,$(1))
        $(SED) 's,^\(include\|lib\)dir=,\0$(STAGING_DIR)/usr/\1,' "$(1)/usr/lib/pkgconfig/evhtp.pc"