treewide: refactor to use PKG_BUILD_FLAGS:=lto
[feed/packages.git] / libs / libgd / Makefile
index 9e0108915a878657eec3d26f13113e17be00664d..750733fecd42ddae6890d056748dbe264e11b1a0 100644 (file)
@@ -20,6 +20,8 @@ PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=COPYING
 PKG_CPE_ID:=cpe:/a:libgd:libgd
 
+PKG_BUILD_FLAGS:=lto
+
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
 
@@ -77,7 +79,7 @@ define Package/libgd/config
        endif
 endef
 
-TARGET_CFLAGS += $(FPIC) -ffunction-sections -fdata-sections -flto
+TARGET_CFLAGS += $(FPIC) -ffunction-sections -fdata-sections
 
 CMAKE_OPTIONS += \
        -DENABLE_FONTCONFIG=OFF \