liblo: disable tests and enable IPv6
[feed/packages.git] / libs / liblo / Makefile
index 27b4f658a0ffab237882c2e042e42c9fe075f276..6eb4e2ee09e2c632b841a80915a7e6c5417f7998 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=liblo
 PKG_VERSION:=0.30
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/liblo
@@ -45,6 +45,13 @@ $(call Package/liblo/Default)
   DEPENDS:= +liblo
 endef
 
+CONFIGURE_ARGS += \
+       $(if $(CONFIG_IPV6),--enable,--disable)-ipv6 \
+       --enable-threads \
+       --disable-examples \
+       --disable-network-tests \
+       --disable-tests
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/lo $(1)/usr/include/