libmad: update to 0.16.1
[feed/packages.git] / libs / libmad / patches / 010-cmake.patch
diff --git a/libs/libmad/patches/010-cmake.patch b/libs/libmad/patches/010-cmake.patch
new file mode 100644 (file)
index 0000000..f5ac246
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -62,6 +62,7 @@ elseif(CMAKE_SYSTEM_PROCESSOR MATCHES ".
+   message(STATUS "Using ARM fixed point math")
+   option (FPM_ARM "ARM fixed point math" ON)
+   if(ASO)
++    enable_language(ASM)
+     target_compile_definitions(mad PRIVATE ASO_INTERLEAVE1 ASO_IMDCT)
+     target_sources(mad PRIVATE imdct_l_arm.S)
+   endif()