libnetfilter-acct: fix license, cleanup
[feed/packages.git] / libs / libnetfilter-acct / Makefile
index b54222ac46332a6472fcf9194746702b6e196ab1..892660716270d6064ace4e28c91722eb423dceeb 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2014 OpenWrt.org
+# Copyright (C) 2009-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -18,7 +18,7 @@ PKG_SOURCE_URL:= \
        http://mirrors.evolva.ro/netfilter.org/libnetfilter_acct/
 PKG_MD5SUM:=2118d9514c079839ebd9cb3144ad2ad7
 
-PKG_LICENSE:=LGPL-2.1
+PKG_LICENSE:=LGPL-2.1+
 PKG_LICENSE_FILES:=COPYING
 PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
 
@@ -30,9 +30,9 @@ include $(INCLUDE_DIR)/package.mk
 define Package/libnetfilter-acct
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libmnl
   TITLE:=API to extended accounting infrastructure
   URL:=http://www.netfilter.org/projects/libnetfilter_acct/
+  DEPENDS:=+libmnl
 endef
 
 define Package/libnetfilter-acct/description
@@ -46,21 +46,16 @@ CONFIGURE_ARGS += \
        --enable-static \
        --enable-shared \
 
-CONFIGURE_VARS += \
-       LIBNFNETLINK_CFLAGS="$(TARGET_CPPFLAGS)" \
-       LIBNFNETLINK_LIBS="$(TARGET_LDFLAGS)"
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/include/libnetfilter_acct \
                $(1)/usr/include/
-
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/libnetfilter_acct*.{so*,a,la} \
                $(1)/usr/lib/
-
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libnetfilter_acct.pc \