libtorrent: update to 0.13.6, disable ipv6, remove ipv6 hack
[feed/packages.git] / libs / libtorrent / Makefile
index 2001235a993f80d3c9f8accc1919fd795ec36ffa..6b41e87b87b71f86c2b015dc1d5d10e73c3e719a 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2013 OpenWrt.org
+# Copyright (C) 2007-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libtorrent
-PKG_VERSION:=0.13.4-git-1
+PKG_VERSION:=0.13.6-git-1
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/rakshasa/libtorrent.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=72e908707f01ee01a9b4918436c64348878b63f7
+PKG_SOURCE_VERSION:=14e793b75dac95c51ad64ff9cd2dc6772b68c625
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 
 PKG_FIXUP:=autoreconf
@@ -50,7 +50,7 @@ CONFIGURE_ARGS+= \
        --enable-openssl \
        --disable-instrumentation \
        --with-zlib=$(STAGING_DIR)/usr \
-       $(call autoconf_bool,CONFIG_IPV6,ipv6)
+       --disable-ipv6
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include