libupm: Update to 1.7.1
[feed/packages.git] / libs / libupm / patches / 001-version.patch
index 3d4fd6cac67cceb7bb0fce3e257a0b9f2ef06389..ef07c25dc34cd5fab022140b7a54f06d0b48b06c 100644 (file)
@@ -1,16 +1,18 @@
 --- a/CMakeLists.txt
 +++ b/CMakeLists.txt
-@@ -26,12 +26,7 @@
include(GNUInstallDirs)
+@@ -225,14 +225,7 @@ include(GNUInstallDirs)
set (LIB_INSTALL_DIR "${CMAKE_INSTALL_LIBDIR}" CACHE PATH "Installation path for libraries")
  
  # Make a version file containing the current version from git.
 -include (GetGitRevisionDescription)
 -git_describe (VERSION "--tags")
--if ("x_${VERSION}" STREQUAL "x_GIT-NOTFOUND")
--  message (WARNING " - Install git to compile a production UPM!")
--  set (VERSION "v0.4.0-dirty")
+-# If git_describe fails, use a dirty version
+-if (${VERSION} MATCHES -NOTFOUND)
+-  set (VERSION "v1.7.1")
+-  message (WARNING "Failed to retrieve UPM version with 'git describe' (using "
+-      "${VERSION}). Check that git is installed and this is a valid git repo.")
 -endif ()
-+set (VERSION "v0.4.0")
++set (VERSION "v1.7.1")
  
- message (INFO " - UPM Version ${VERSION}")
+ message (STATUS "UPM Version ${VERSION}")