libupm: Update to 1.7.1
[feed/packages.git] / libs / libupm / patches / 003-link-atomic.patch
diff --git a/libs/libupm/patches/003-link-atomic.patch b/libs/libupm/patches/003-link-atomic.patch
new file mode 100644 (file)
index 0000000..e7e9959
--- /dev/null
@@ -0,0 +1,8 @@
+--- a/src/nmea_gps/CMakeLists.txt
++++ b/src/nmea_gps/CMakeLists.txt
+@@ -6,4 +6,4 @@ upm_mixed_module_init (NAME nmea_gps
+     CPP_SRC nmea_gps.cxx
+     FTI_SRC nmea_gps_fti.c
+     CPP_WRAPS_C
+-    REQUIRES mraa utilities-c ${CMAKE_THREAD_LIBS_INIT})
++    REQUIRES mraa utilities-c atomic ${CMAKE_THREAD_LIBS_INIT})