opus: update to 1.5.1
[feed/packages.git] / libs / opus / Makefile
index 978198baa6bda51bba8d42699ca96ea81ea5b600..da931c6dbbc92321a74d4f8312f87bf88afa74f2 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=opus
-PKG_VERSION:=1.4
+PKG_VERSION:=1.5.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://downloads.xiph.org/releases/opus
-PKG_HASH:=c9b32b4253be5ae63d1ff16eea06b94b5f0f2951b7a02aceef58e3a3ce49c51f
+PKG_HASH:=b84610959b8d417b611aa12a22565e0a3732097c6389d19098d844543e340f85
 
 PKG_MAINTAINER:=Ted Hess <thess@kitchensync.net>, Ian Leonard <antonlacon@gmail.com>
 PKG_LICENSE:=BSD-3-Clause
@@ -24,6 +24,7 @@ PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/meson.mk
 
 define Package/libopus
   SECTION:=libs
@@ -38,23 +39,23 @@ define Package/libopus/description
  is also intended for storage and streaming applications.
 endef
 
-CONFIGURE_ARGS+= \
-       --disable-doc \
-       --disable-extra-programs
+MESON_ARGS+= \
+       -Ddocs=disabled \
+       -Dextra-programs=disabled
 
 ifeq ($(CONFIG_SOFT_FLOAT),y)
-       CONFIGURE_ARGS+= \
-               --enable-fixed-point
+       MESON_ARGS+= \
+               -Dfixed-point=true
 endif
 
 ifneq ($(findstring neon,$(CONFIG_CPU_TYPE))$(findstring aarch64,$(CONFIG_ARCH)),)
-       CONFIGURE_ARGS+= \
-               --enable-fixed-point
+       MESON_ARGS+= \
+               -Dfixed-point=true
 endif
 
 CPU_ASM_BLACKLIST:=xscale arm926ej-s
 ifneq ($(findstring $(call qstrip,$(CONFIG_CPU_TYPE)),$(CPU_ASM_BLACKLIST)),)
-       CONFIGURE_ARGS+= --disable-asm
+       MESON_ARGS+= -Dasm=disabled
 endif
 
 define Build/InstallDev