postgresql: update to version 15.1
[feed/packages.git] / libs / postgresql / patches / 200-ranlib.patch
index 3bf02efeeafadd1026ff935c45dd397cb1ade1c7..d4184a35427cf2ec0f28c54cabd9b3c1d6378d9e 100644 (file)
@@ -1,10 +1,10 @@
 --- a/src/port/Makefile
 +++ b/src/port/Makefile
-@@ -84,6 +84,7 @@ uninstall:
+@@ -83,6 +83,7 @@ uninstall:
  libpgport.a: $(OBJS)
        rm -f $@
        $(AR) $(AROPT) $@ $^
 +      $(RANLIB) libpgport.a
  
- # thread.o and thread_shlib.o need PTHREAD_CFLAGS (but thread_srv.o does not)
thread.o: CFLAGS+=$(PTHREAD_CFLAGS)
+ # getaddrinfo.o and getaddrinfo_shlib.o need PTHREAD_CFLAGS (but getaddrinfo_srv.o does not)
getaddrinfo.o: CFLAGS+=$(PTHREAD_CFLAGS)