protobuf: Fix host build
[feed/packages.git] / libs / protobuf / Makefile
index fb2d84fddd8851b51bc5f6260797f64758e5dd95..a4310b4f51001431ab343fddf1989713eb98e6d9 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=protobuf
 PKG_VERSION:=3.8.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-cpp-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/google/protobuf/releases/download/v$(PKG_VERSION)
@@ -68,7 +68,10 @@ endef
 
 CMAKE_HOST_OPTIONS += \
        -Dprotobuf_BUILD_PROTOC_BINARIES=ON \
-       -Dprotobuf_BUILD_TESTS=OFF
+       -Dprotobuf_BUILD_TESTS=OFF \
+       -DBUILD_SHARED_LIBS=ON \
+       -DCMAKE_SKIP_RPATH=OFF \
+       -DCMAKE_INSTALL_RPATH="${STAGING_DIR_HOSTPKG}/lib"
 
 CMAKE_OPTIONS += \
        -Dprotobuf_BUILD_PROTOC_BINARIES=ON \