Merge pull request #3714 from weblate/weblate-openwrt-luci
[project/luci.git] / luci.mk
diff --git a/luci.mk b/luci.mk
index 2745797c1f3448a67306abfd35f51fbaa221c0fd..522a21e763e63291f6a60d5c7298078911c9761d 100644 (file)
--- a/luci.mk
+++ b/luci.mk
@@ -30,7 +30,7 @@ LUCI_LANG.mr=Marāṭhī (Marathi)
 LUCI_LANG.ms=Bahasa Melayu (Malay)
 LUCI_LANG.nb_NO=Norsk (Norwegian)
 LUCI_LANG.pl=Polski (Polish)
-LUCI_LANG.pt_BR=Português do Brasil (Brazialian Portuguese)
+LUCI_LANG.pt_BR=Português do Brasil (Brazilian Portuguese)
 LUCI_LANG.pt=Português (Portuguese)
 LUCI_LANG.ro=Română (Romanian)
 LUCI_LANG.ru=Русский (Russian)
@@ -221,20 +221,13 @@ define Package/$(PKG_NAME)/install
        else true; fi
 endef
 
-ifneq ($(LUCI_DEFAULTS),)
+ifndef Package/$(PKG_NAME)/postinst
 define Package/$(PKG_NAME)/postinst
 [ -n "$${IPKG_INSTROOT}" ] || {$(foreach script,$(LUCI_DEFAULTS),
        (. /etc/uci-defaults/$(script)) && rm -f /etc/uci-defaults/$(script))
        rm -f /tmp/luci-indexcache
        rm -rf /tmp/luci-modulecache/
-       exit 0
-}
-endef
-else
-define Package/$(PKG_NAME)/postinst
-[ -n "$${IPKG_INSTROOT}" ] || {
-       rm -f /tmp/luci-indexcache
-       rm -rf /tmp/luci-modulecache/
+       killall -HUP rpcd 2>/dev/null
        exit 0
 }
 endef