ssmtp: revoke gnutls support
[feed/packages.git] / mail / ssmtp / Makefile
index 0352f781a954b0c6b3c756beb90491f10ba240ec..3d243947773c9d82b415f9459de725c72bc2afa5 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ssmtp
 PKG_VERSION:=2.64
-PKG_RELEASE:=1
+PKG_RELEASE:=1.1
 PKG_MAINTAINER:=Dirk Brenken <dibdot@gmail.com>
 PKG_LICENSE:=GPL-2.0+
 
@@ -24,8 +24,8 @@ TARGET_CFLAGS += $(TARGET_CPPFLAGS)
 define Package/ssmtp
   SECTION:=mail
   CATEGORY:=Mail
-  DEPENDS:=+libgnutls-openssl
-  TITLE:=A minimal and secure mail sender with gnutls support
+  DEPENDS:=+libopenssl
+  TITLE:=A minimal and secure mail sender with ssl support
   URL:=http://packages.debian.org/ssmtp
 endef
 
@@ -33,7 +33,7 @@ define Package/ssmtp/description
  A secure, effective and simple way of getting mail off a system to your
  mail hub. It contains no suid-binaries or other dangerous things - no
  mail spool to poke around in, and no daemons running in the background.
mail is simply forwarded to the configured mailhost. Extremely easy
Mail is simply forwarded to the configured mailhost. Extremely easy
  configuration.
 endef
 
@@ -43,7 +43,7 @@ define Package/ssmtp/conffiles
 endef
 
 CONFIGURE_VARS += \
-       LIBS="$(TARGET_LDFLAGS) -lgnutls-openssl"
+       LIBS="$(TARGET_LDFLAGS) -lcrypto -lssl"
 
 CONFIGURE_ARGS += \
        --enable-ssl