xmail: Update to version 1.27
[openwrt/svn-archive/packages.git] / mail / xmail / patches / 010-Makefile.common.patch
index af6aa709f637a13913b63021172bff89fab01e10..0417268e8119213d898156f76e15b9e001b36de0 100644 (file)
@@ -1,11 +1,11 @@
 --- a/Makefile.common
 +++ b/Makefile.common
-@@ -76,15 +76,15 @@
- SENDMAILOBJS = SendMail.o
+@@ -77,15 +77,15 @@ SENDMAILOBJS = $(addprefix $(OUTDIR)/, $
  
- %.o : %.cpp
--      ${CC} ${CPPFLAGS} ${CFLAGS} -c $*.cpp
-+      ${CXX} ${CPPFLAGS} ${CFLAGS} -c $*.cpp
+ $(OUTDIR)/%.o: %.cpp
+-      ${CC} ${CPPFLAGS} ${CFLAGS} -o $(OUTDIR)/$*.o -c $*.cpp
++      ${CXX} ${CPPFLAGS} ${CFLAGS} -o $(OUTDIR)/$*.o -c $*.cpp
  
  all: ${OUTDIR} ${MKMACHDEPINC} ${MAILSVR} ${CRTLCLNT} ${XMCRYPT} ${MKUSERS} ${SENDMAIL}